Home > Rails Error > Rails Error Write_inheritable_attribute

Rails Error Write_inheritable_attribute

Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. Install the ruby-iconv port... ruby -v gem -v b) Did you try to install Rails using the following? share|improve this answer answered Dec 12 '13 at 8:34 Jeremy F. 860925 I'm having the same problem and would love an explanation. –Alex Villa Mar 17 '14 at 3:14 http://vealcine.com/rails-error/rails-error.php

sudo gem install rails -Conrad Report post Edit Delete Reply with quote Re: Rails issue when using Rails 2.3.2 and Ruby 1.9.1 Doug Lilla (dunebaba) on 2009-06-04 16:08 Conrad Taylor wrote: yes examine files in directory /Users/douglilla/.gem/ruby/1.8/cache? How can I get this server to run? Somehow installing this version must have be set as "default".

Use following command and problem gone gem install rails This will install updated rails and all thing working find again. Three ways to fix it: gem install rails to install a newer version of Rails (you may have to specify a version >= 3.0) Run the app with bundle exec rails My set-up was working fine until I > upgraded. No registration required!

command in Rails version 2 is a generator, equivalent to rails new ... Join them; it only takes a minute: Sign up Problems running rails server up vote 0 down vote favorite I just installed the rails env using the Rails installer on my yes > > Apparently a lot of gems got installed in the wrong directory?? > > Thanks, > > DL DL, all you gems should be installed in the following: For Cooking inside a hotel room Does store bought barbecue sauce need to be heated/cooked before consumption?

Ruby-Forum.com Ruby Ruby Ruby on Rails JRuby Ruby Jobs About this forum Ruby-Forum Non-English Italian Ruby Group Forum: Ruby on Rails Rails issue when using Rails 2.3.2 and Ruby 1.9.1 Forum share|improve this answer answered Sep 2 '12 at 15:41 Bijendra 3,32821941 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign Existing account User name or e-mail address Password Always use SSL (experimental!) NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Unfortunately, you died Save a JPG without a background DXA model mapping issue What is "If ghash.io hits 51% people would just leave them?" referring to? Would you like to answer one of these unanswered questions instead? Solution in all 3 is to gem install rails. –Michael Berkowski Sep 2 '12 at 15:20 Did you install rails using homebrew? –coletrain Sep 2 '12 at 15:21 add We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

Also, if you have ruby 1.8.6 installed on FreeBSD, you need to install iconv separately through the converters/ruby-iconv port. Contact information - E-Mail: webmaster (at) ruby-forum (dot) com. Для работы с обсуждениями в Группах Google включите JavaScript в настройках браузера и обновите страницу. . Мой аккаунтПоискКартыYouTubePlayПочтаДискКалендарьGoogle+ПереводчикФотоЕщёДокументыBloggerКонтактыHangoutsДругие сервисы GoogleВойтиСкрытые поляПоиск групп Log in with Google account | Log in with Yahoo account | Log in with Facebook account No account? January 5, 2009 at 7:23 AM Jeff Schmitz said...

Rails: Gem::InstallError Delete a document from Cloudantdatabase How to install node.js inWindows? get redirected here Jokes about Monica's haircut Discontinuity in the angle of a complex exponential signal Print some JSON When your mind reviews past events Why is the nose landing gear of a Rutan Fetching: rails-3.2.12.gem (100%) Successfully installed rails-3.2.12 C:/Ruby192/> Share this:TweetPrintLike this:Like Loading... As your are using rvm, the folder path displayed here shows rails 2.3.4, while you tried to run rails server .

My project was using Rails 3.x but when I ran rails -v I got 2.3.17 which is the version used by a project I worked on just before. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 195 Star 8,160 Fork 1,828 thoughtbot/paperclip Code Issues 82 Pull requests 16 Projects Mine is 3.2.11 but the current stable is 3.2.12. navigate to this website Active Support relies on iconv but if you load Active Record without incov installed, it will silently fail and tell you it couldn't find cattr_accessor, which is part of Active Support.

share|improve this answer edited May 3 '15 at 9:40 Arslan Ali 8,49161841 answered Oct 2 '12 at 6:09 Michael Ryan Soileau 547412 add a comment| up vote 7 down vote I up vote 0 down vote favorite I attempted to generate a migration like: rails generate migration RemovefromGenotypes box:integer well:string but then I get this error: /usr/share/rails-ruby1.8/railties/lib/rails_generator/options.rb:32:in `default_options': undefined method `write_inheritable_attribute' for You may need to install a stable snapshot to get iconv with ruby 1.8.7.

Thank you very much.

can't load kernel32 Hot Network Questions What is way to eat rice with hands in front of westerners such that it doesn't appear to be yucky? It seems that you use ruby built locally on your machine, don't you?Could you please run "gem env" command and post it here.Regards,Oleg Permalink 0 hendri firmana June 05, 2009 09:46 Thanks Sprewell. I create a project using the "rails new" command.

Discontinuity in the angle of a complex exponential signal Americanism "to care SOME about something" How to slow down sessions? What's a Racist Word™? The last existing version (v3.1.0) is shown here. write_inheritable_attribute(key, value) public No documentation This method has no description. my review here Register here.

Is there a standard I2C/SM bus protocol for laptop battery packs When to use "ĉu" instead of "se"? Why generic lambdas are allowed while nested structs with templated methods aren't? share|improve this answer answered Jun 18 '12 at 7:53 vajapravin 83211425 add a comment| up vote 7 down vote Running bundle exec rails s worked for me. I ran the following: gem uninstall rmagick gem cleanup And then re-ran bundle in my stack and it worked for me again.

Tags.gemrc acceptance testing activerecord apache atom-editor backbonejs batch bluemix builderror bundle exec bundle install centos cf cloudantdb cloudfoundry cron curl debian designpatterns devkit django docker editor elasticsearch facebook git htaccess installerror In my Gemfile: gem 'rmagick' gem 'paperclip', :git => 'git://github.com/thoughtbot/paperclip.git' Do you know what's going on with this? ruby-on-rails ruby share|improve this question asked Sep 2 '12 at 15:18 harristrader 2912619 See this, this, and this. Show source # File activesupport/lib/active_support/core_ext/class/inheritable_attributes.rb, line 132 def write_inheritable_attribute(key, value) if inheritable_attributes.equal?(EMPTY_INHERITABLE_ATTRIBUTES) @inheritable_attributes = {} end inheritable_attributes[key] = value end Register or log in to add new notes.

I cannot do much of anything in my app while this error is preventing me from running requests. share|improve this answer answered Apr 13 '13 at 22:17 fotanus 10.3k54677 add a comment| up vote 0 down vote (@jeremy-f and @alex-villa are on the right track to identifying the problem The solution is to make sure iconv is installed. See below: C:/Ruby192/lib/ruby/gems/1.9.1/gems/rails-1.1.5/lib/rails_generator/options.rb:33:in `default_options': undefined method `write_inheritable_attribute' for Rails::Generator::Base:Class (NoMethodError) from C:/Ruby192/lib/ruby/gems/1.9.1/gems/rails-1.1.5/lib/rails_generator/base.rb:51:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/rails-1.1.5/lib/rails_generator/base.rb:46:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/rails-1.1.5/lib/rails_generator/base.rb:18:in `' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/rails-1.1.5/lib/rails_generator/base.rb:17:in `' from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:53:in `require' from C:/Ruby192/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:53:in `require' from C:/Ruby192/lib/ruby/gems/1.9.1/gems/rails-1.1.5/lib/rails_generator.rb:34:in