Home > Python Error > Python Error Pythreadstate_get No Current Thread

Python Error Pythreadstate_get No Current Thread


I pinged mxcl, and hopefully he will determine what changed because this was working 12 days ago. Already downloaded: /Library/Caches/Homebrew/graphviz-2.38.0.tar.gz ==> Downloading https://trac.macports.org/export/103168/trunk/dports/graphics/gr Already downloaded: /Library/Caches/Homebrew/graphviz--patch-b242fb8fa81489dd16830e5df6bbf5448a3874d5.diff ==> Patching patching file macosx/graphviz.xcodeproj/project.pbxproj ==> ./configure --prefix=/usr/local/Cellar/graphviz/2.38.0 --without-qt --with-q ==> make install 🍺 /usr/local/Cellar/graphviz/2.38.0: 504 files, 69M, built in 54 seconds Try python -v to see exactly what module is being imported before the crash. –mata Feb 6 at 9:15 Thanks mata, Last few lines are import encodings.ascii # precompiled A word for acting in advance of some expected or anticipated outcome Next number in sequence, understand the 1st mistake to avoid the 2nd Can the notion of "squaring" be extended this contact form

OS X provides an older sqlite3. xlfe commented Sep 22, 2012 ok thanks. Generally there are no consequences of this for you. MacPorts trace mode (the -t flag) should prevent this kind of problem from happening. https://github.com/Homebrew/legacy-homebrew/issues/13654

Fatal Python Error: Pythreadstate_get: No Current Thread Homebrew

Therefore, I will try to find a way to put the sitecustomize.py - which fixes these issue - in our site-packages even if no python has been brewed. Not that I know of, is there a way I can check that with a cmd? About the author vinllen chen Beijing, China 格物致知 Discussions Please enable JavaScript to view the comments powered by Disqus.

  1. Success!
  2. I will try it and let you know.
  3. The person reporting the bug can probably work around this problem by setting the environment variable DYLD_LIBRARY_PATH to /opt/local.
  4. Endpoint : http://nao.local:9559 Make sure NAOqi is running and the IP you used in ALProxy constructor is correct RuntimeError: ALNetwork::getModuleByName failed to get module MyModule http://nao.local:9559 Make sure you spelt the

Could you give me further suggestions? Replacing PYTHON_LIBS="-lpython$PYTHON_VERSION_SHORT" with PYTHON_LIBS="`python-config --ldflags`" in configure seems to do the trick. xlfe commented Sep 22, 2012 pvtl:Sharehouse Game felix$ brew --config HOMEBREW_VERSION: 0.9.3 HEAD: c5ebc7a HOMEBREW_PREFIX: /usr/local HOMEBREW_CELLAR: /usr/local/Cellar CPU: quad-core 64-bit ivybridge OS X: 10.8.2-x86_64 Xcode: 4.5 CLT: LLVM-GCC: build Fatal Python Error: Pythreadstate_get: No Current Thread Anaconda I tried these steps, and it worked for me.

Try solution: python-config --ldflags copy the output to corresponding MakeFile. Fatal Python Error: Pythreadstate_get: No Current Thread Swig Reload to refresh your session. more hot questions question feed lang-py about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation edit retag flag offensive close merge delete CommentsHaving the same issue.Tom Moore( 2014-11-27 08:21:13 -0500 )editUnfortunately I think you need to recompile everything, since all the packages which built against Python

Thanks!P.s. Mayavi Fatal Python Error: Pythreadstate_get: No Current Thread Please note that it does not mean that you have to make it system default, just make sure to start PyRosetta with /usr/bin/python. I am new to this. samueljohn commented Nov 9, 2012 grrr ...

Fatal Python Error: Pythreadstate_get: No Current Thread Swig

python multithreading osx boost-python nupic share|improve this question asked Feb 6 at 8:57 magaga 214 nupic, which seems to be a pure python library, probably isn't the culprit here, Check This Out Note: See TracTickets for help on using tickets. Fatal Python Error: Pythreadstate_get: No Current Thread Homebrew Fixes #32180. 90fa9e3 tdsmith added a commit to tdsmith/homebrew that referenced this issue Sep 9, 2014 tdsmith weblink I have no idea why it crashes for you. Whenever I try to run python scripts such as rostopic or rosrun rqt_graph rqt_graph, I get the following error: Fatal Python error: PyThreadState_Get: no current thread Abort trap: 6 I understand Homebrew member tdsmith commented Sep 9, 2014 It looks like the homebrew bin directory probably isn't in your PATH? Fatal Python Error: Pythreadstate_get: No Current Thread Vtk

How did you solve it please? –Jack Twain Mar 6 '14 at 23:47 @AlexTwain is just a placeholder name. Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. Is there anything I can do now, short of re-installing ROS again? navigate here When I open python and run import gtk, python segfaults, and it seems this issue is not new.

Not the answer you're looking for? Fatal Python Error Pythreadstate_get No Current Thread Abort -trap See also ticket #43086 comment:18 follow-ups: ↓ 19 ↓ 20 Changed 3 years ago by [email protected]… Resolution set to invalid Status changed from new to closed This problem is likely caused by having So, now you @2bits try to brew rm python pygobject pygtk py2cairo and install them again and try to reproduce :-) 2bits commented Nov 9, 2012 I guess I edited my

And what happens when you $ python >>> import cairo >>> import gobject >>> ctrl-d staticfloat commented Sep 26, 2012 I don't have a PYTHONPATH environment variable.

Your work on python has paid off. Mac OS X already provides this software and installing another version in parallel can cause all kinds of trouble. To check the complete list of modules and method names, see section NAOqi APIs Weird float errors¶ If you notice that floats are trucated when they are the result of the Fatal Python Error: Pythreadstate_get: No Current Thread Root Browse other questions tagged python multithreading osx boost-python nupic or ask your own question.

Reference: https://wolfpaulus.com/journal/mac/installing_python_osx/ http://stackoverflow.com/questions/15678153/homebrew-python-on-mac-os-x-10-8-fatal-python-error-pythreadstate-get-no-cu Posted on python, OSX Liked this post ? adamv closed this Nov 11, 2012 samueljohn commented Dec 6, 2012 Well, even if this is old now and closed... ... Do I need to do something with Python before recompiling? his comment is here Will leave this and see if one of our more Pythony folks have ideas.

Fixes #32180. 66ba9c2 tdsmith referenced this issue Sep 9, 2014 Closed graphviz: add python lib dir to linker search path #32194 BrewTestBot added a commit to BrewTestBot/homebrew that referenced I can import gtk. — Reply to this email directly or view it on GitHub<#13654 (comment)>. 2bits commented Sep 22, 2012 We have the same config, though I used Homebrew python Fixes #32180. Fixes #32180.">graphviz: learn python ldflags from python-config … Use python-config --ldflags to make sure the active python framework's lib directory is in the linker search path.

Though it's not quite the same, it can be a reference. But, perhaps you had a different problem than what we were able to reproduce an fix. Version mismatch¶ Version mismatch Your version of Python does not match the one with which the Python SDK was made. pvtl:~ felix$ brew doctor Warning: /usr/bin occurs before /usr/local/bin This means that system-provided programs will be used instead of those provided by Homebrew.

Signed-off-by: Mike McQuaid ">graphviz: add $PYTHON_PREFIX/lib to linker search path … Make sure the active python framework's lib directory is in the linker search path. Fri, 2013-01-18 10:56 rmoretti Log in or register to post comments #3 Top PyRosetta binaries will work only with build-in 'Apple' python. I'm not totally sure this interacts the right way with depends_on :python or I'd open a PR. According to @Evert's comments of different libraries used by different python, I tried to revert the python27-apple to be "active".